You are here: start » system_requirements

System Requirements

CMSimple_XH is designed to run on almost every internet server. The server- and client-side requirements for installing, administrating and running CMSimple_XH are listed in the following sections.

Web Server

CMSimple_XH requires PHP 4.3.10 or higher (successfully tested up to 7.1). At least PHP 5.6 is recommended, though; if the server is running an older PHP version, you can probably switch to PHP 5.6 or higher in the wespace's control panel. The PHP extensions “date”, “pcre”, “session” and “xml” have to be installed, what's normally the case everywhere.

No database is required, as all data are stored in flat files.

An Apache HTTP server is recommended, but CMSimple_XH should also run on other servers (successfully tested with IIS and NGINX).

Your Personal Computer

You need an FTP client to upload and download files and folders to the server and to assign reading and writing permissions.

And of course you need a browser to administrate your site. The newest version of Firefox, Internet Explorer, Chrome, Safari or Opera are recommended. It's mandatory to have javascript and Cookies enabled. Because popup and ad blockers might suppress important dialogs and other functionality, you have to disable them when necessary or you have to add respective exceptions to the popup or ad blocker.

Extensions

Some extensions might have more demanding requirements, for example some plugins require PHP 5 to function properly. This should be mentioned in the dokumentation of the respective extensions.

 
You are here: start » system_requirements
Except where otherwise noted, content on this wiki is licensed under the following license: GNU Free Documentation License 1.3
Valid XHTML 1.0 Valid CSS Driven by DokuWiki